Let's Make Robots!

Pololu dual motor controller + Tamiya 70168

I bought a Tamiya 70168 twin gearbox and Tamiya wheels and hooked them up to my Pololu micro dual serial motor controller.  They don't even budge.  I hooked up GM-10 motors and they work as they should.  I changed motor power to 9v instead of 6v, motor 0 turned for a second and stopped.  Again the GM-10 motors ran fine.  If I apply power direct to Tamiya from battery, either 6v (4 @ AA) or 9v (9v cell), it turns as you would expect.  All of this was done with no load on Tamiya, the wheels were not even touching the ground.  I used freshly charged batteries.

 Any ideas?  I'm stumped.  Would a 0.1 uF capacitor across the motor leads help?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
L293 D , the same used in the start here project... is there a way to check it or do i just have to read the manual (which i have to find on the net)?

Stick your voltmeter across the motor leads while the robot is trying to drive forward. Ideally, to be the most accurate, you should measure it under load (i.e., not with the wheels in the air). But either way, you'll know exactly how much power is actually making it to the motors. Considering the voltage drop of the motor driver, 4 rechargeables may be your best option -- you may not end up overdriving the motors at all.

Dan

BTW, because the Mabuchi FA-130 motors that come with those Tamiya kits are designed to run on 3v, feeding them 9v will shorten their life. Be sure to check out the link to the voltage test at the bottom of that page -- one of Pololu's customers got a bunch of those motors and tested them at different voltages and measured how long they lasted, and took pictures of what they looked like inside when they died. Interesting reading.

In my current project, I'm using a Tamiya twin gearbox plus some servos, and I didn't want to drive the servos off of 3v, so I decided to just use 4 rechargeable AAs. I'm slightly overpowering the Mabuchi motors, but they only cost $2 each, so I figure it's not too much of a risk :)

Dan

That's a nice writeup on the voltage tests.  Interesting results.  I agree with you, for $2, I can afford to get more power and less life out of the motors.

Now just waiting for my LVDSMC to arrive, but that gives me time to redesign, again.

The motors that come with the Tamiya kits are designed for use in toys and stuff, and so they're designed to run off of just one or two AA batteries. In order to perform decently at such low voltage, they draw quite a lot of current -- up to several amps. The micro DSMC can't put out enough current to drive them. Pololu has another motor controller designed specifically for these toy motors -- the Low-Voltage Dual Serial Motor Controller. In fact, they even offer that controller in a bundle with the Tamiya double gearbox, showing clearly that that's exactly what they had in mind when they designed it. It's definitely the way to go. Unfortunately, I don't think the uDSMC will be able to drive those motors.

And of course, it's always a good idea to add the .1 uF caps on your motors, though I'm pretty sure it won't help you with this problem.

Dan

Thanks Dan!

Figures...  I saw the bundle option, I should have bought it and saved a few bucks.  Live and learn.

I'm kind of confused on this.  The diagram shows 2 cap sonfigurations, from motor leads to motor case and across the leads.  I had always assumed caps should go across the leads but I'm not really sure now.  Is there a reason to put one leg on the motor casing?

caps.jpg

I don't know of any good reason to run them to the casing rather than directly across the leads. I'm curious what the benefit might be, but anytime I've seen pictures of electric motors online, they just had the cap directly across the leads, so that's how I do mine. Maybe on some motors the leads are too far apart to comfortably run a single capacitor across them?

Dan