Let's Make Robots!

ultrasonic sensors from Cybot

I'm trying to understand this sonar-board from my old cybot robot, but I think I will need a little help :

http://www.lpilsley.co.uk/cybot/sonario.htm

- If I'm correct I should put a voltage on the transmitter sensors for a short period of time (100 ms?), then read in the value of pin 2 and 3, right?

- What voltage should the transmitters get? 5V?

- I do not know which are the transmitters and/or the receivers : on 2 sensors there's a mark : "2F" and on the other 2 it reads : "2H", but which are which? 

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

i remember buying the magazine every single week, for 4 weeks and stopped. I should have bought it all at once, kinda expensive though. as for the ultrasonic sensors, hmmm, no experience with those yet, i personally do not like them due to the slow sampling rates

Damn, thats the problem, there is no part number just the 2F and 2H.

Even Google can't help me :(

 

Maybe its better if I buy new ones? or directly buy Parallax Ping)))) ?

TeleFox's picture

The Ping))) modules have a lot built in, so they're easy to use. You could always try the parts you have now and replace them if they don't work, since the ultrasonic transducers are so cheap by themselves.

TeleFox's picture

• You can't just send a fixed voltage to your ultrasonic transmitters to turn them on, unless they've got integrated drivers (not likely). Instead you'll need to send a 40kHz square wave to each of the 2 transmitter pins in counter-phase. This means you'll need to send 5V and then 0V 40,000 times per second to pin 5, and send the opposite to pin 6. This means that when pin 5 is 5V, pin 6 is 0V and vice versa, producing a stonger output signal.
The length of this 40kHz pulse should be long enough for you to read in the response from the receivers, but short enough that the transmitter stops transmitting with a little bit of time left before the returning echo hits the receivers. You'll have to figure this out based on your microcontroller and programming choices.

• 5V is normally fine, these things are pretty tough. Can't know for certain without a part number though.

• Once again without a part number I can't say, 2F and 2H don't sound familiar.
Do any of the 4 sensors look different from each other? Sometimes the transmitters and receivers will look subtly different.