Let's Make Robots!

PIC to Ligicator - Serious noob here

Hey all, ive just received quite a few componants tho i dont know what most of them do, i am learning about the datasheets of each peice that i have tho, i just need to know a few things and any support i can get to get this thing rolling...

Processors i have:

uM-FPU coprocessor (V2) // PICAXE-08M microcontroller // PICAXE-18X microcontroller //PICAXE 28X2 microcontroller

 

my goal is to interface with the program called "logicator" so i can see the code and learn from it and eventually code my own output

i have:

(USB AXE027 interface) 100 (10k Resistors) and 100 (0r resistors), (18 Blue LEDS) (diods bat85) (rectifier diods 1n4001) (transistors bcx38c) 3 pin (resonators 10mhz) and (15 100nF Capcitors) and large amounts of CAT5 Cable

 

As you can see i have put some images bellow, please inspect them, this is my first ever time making my own hardware, but i will learn quickly as i have wanted to do this for many years now.

 

ok my problem  is: I am running the PICAXE-08M on the bread board

when i connect the usb connector to my Bread Board and scan on COM4 for its PICAXE Type, the blue LED will show and with a voltage of 2.5Volts, (I do not know what the maximum voltage is for these) which is telling me the chip is receiving and sending, but when the light goes out, i get an error on screen:

Error - Hardware not found on COM4!

Possible causes:

1) Hardware not connected (THO IT IS)

2) Hardware not powerd (I thought because the light was on it is drawing power from the usb its self)

3) Hardware needs a reset (i dont even know how to do this lol)

 

Please help me with this! :P i really want to get into creating all types of hardware, and when possible PC controlled VU meters! :D

Any type of feed back would ne nice and i would be very greatfull, My life of building electronics starts here, with you fine people!.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

thanks for the information, so usefull. (y)

Actually you might want to look at page 7 of this manual http://www.rev-ed.co.uk/docs/picaxe_manual1.pdf it looks like you have your circuit all wrong. For example, the middle pin of the download socket goes to serial out but you have it going to the resistors.

You might want to take a few steps back and rethink your approach.

The 'Logicator' software is designed for programming PIC micros. You've bought several PICAXE micros, and you are trying to program them with a PICAXE cable and PICAXE circuitry.
This is not going to work.

Go and find out the difference between a PIC and a PICAXE, get a copy of the actual PICAXE software from http://www.rev-ed.co.uk/picaxe/, read up on how the whole programming method works, and then try again.

If you look at the bottom of this page you can see that i have made the 2 lights flash one after the other, and, ive been programming for years, just with visual basic .NET, and i sucseeded on the first day i got the componants, this was my first real attempt at hands on programming a picaxe module