Let's Make Robots!

It's Alive!

After finally getting all the parts and assembling my new uBotino board, it didn't work! So I grabbed my multimeter and began probing around to find the problem. Got my Dad to hep me since he spent his entire career in electronics. Apparently, this particular board had a couple of places where the etching didn't complete properly. Found a short on the input pin of the voltage regulator and a short on pin 14 of the motor driver. Did some scratching on the input pin line of the voltage regulator to get a good connection and applied a high current, low volt transformer on pin 14 of the motor driver mounting hole and got it to pop through the etching block. Now it works and hums along perfectly!

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Ro-Bot-X's picture

Wow! I had no idea it can be that bad!!! These 10 boards came in with 5 of them being e-tested. I did some tests on the others, but nothing very thorough. I guess you ended up with one of the boards that were not tested by the fabhouse. Sorry about that, but at least I'm glad you found a way to solve the problem. I can send you a V2 board for free if you like. V2 were all tested in the fabhouse.

AlamoRobotics's picture

The circuit was basically good. There were just a couple of places where the etching didn't quite complete the trace. Thanks for the offer, but everything appears to be working fine now so I don't think you need to send me another board. You're already working on a small profit margin. I look at it as a learning experience on how to check and repair circuit boards. Keep up the good work!

Ro-Bot-X's picture

Thanks!

rik's picture

You used electrical current to cut a tiny trace that caused a short? That's smart AND gutsy!

AlamoRobotics's picture

He's been doing electronics since the days of the vacuum tub and he has all sorts of little (not always safe) tricks up his sleeve. We couldn't find the break in the trace even under magnification with a loupe, so he came up with that idea. I was skeptical, but it did reveal a small pin-hole size break (marked by tiny black dot after we applied the current) in the trace very close to the edge of the solder pad that cleared everything up. Now everything works great.