Let's Make Robots!

Battery charging

Hello

 

I have this battery:

it has 6V, 1.3Ah... I don't have a charger... on the side says:

 

cycle use charge 7.25 - 7.45V

Trickle charge: 6.8 - 6.9V

and something about 0.4A

 

now... I have a lab source... or something like this from an old toy... I put on the volt meter and set it for 7.43V, it has an analog pot... than... I put a volt meter on the pins of the battery... I read something about to stop around 6.60...

 

I made a calculation 7.43V + 6V /2 is 6.715V... this should be the V that the battery and the lab source has been equaled so electrons navigates at the same rate from and to... but I have 6.84V right now... and still charging... the battery isn't hot at all... it's Pb based...

 

until when should I charge it?

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

7.1V is more than enough. Once the current drops down to almost nothing, the battery is full. Their spec of 7.25 to 7.43V might be only relevant for a brand new battery and you may not be able to get that high with it once its had a few cycles on it.  I wouldn't worry about trying to get it right to the top.

you are right... I leave it in the charger for 1 more hours after it got to 7.10... it played between 7.10 than dropped to 7.06... doesn't goes over 7.10... it's a brand new battery... this was the second charge

Charge it until it gets to 7.43 volts. The current will drop to almost nothing by then. Lead acid batteries like that basically manage themselves as long as you give them the right voltage.

If you are going to leave it charging forever, then you need to set the voltage to the 6.8 or 6.9V. Otherwise you use the higher voltage to charge up to and then stop. The battery will lose a little bit of that voltage after you finish charging... don't worry.

 

I managed to charge with 7.43 till 7.10... it was 3 AM so I stoped charging but everything is fine now... working like a charm... thank you... next charge I will leave it until 7.43...

 

I noticed during charge that when battery is empty is draws 0.4A as it is specified... as it gets closer to 7V... the ampere drops under 0.1A... that's kind of good... than at 7.10 it stopped somehow... playing between 7.10 - 7.12 and nothing more...