Let's Make Robots!
AttachmentSize
IMG_20110908_095112.jpg715.43 KB
IMG_20110908_095143.jpg710.74 KB

Hi guys,

This is my first robot and I am having some difficulty moving forward with the project.

I hope you can help

The project is a simple Arduino obstacle avoidance.

It's based on the J-Bot robot project from Jameco

http://www.jameco.com/Jameco/workshop/diy/jbotrobot.html

I purchased the parts from Jameco accept for the 4-WD platform. It was not available so I got the 2-WD one

This is what I have done so far

1. Built the motor shield and connected it to the Arduino

2. Attached the 2 motors and the wheels

As you can see in the photos :

I have 2 battery holders ( one for 6 AA batteries = 9 Volts and the other for 5 AA batteries = 7.5 volts)

My Question

I understood from the site that the Arduino should be connected to the 9 Volts (6 AA) and the motor shield to the 7.5 Volts Is this correct?

I don't want to mess things ...

and Is there a way to test the motor shield connected to the Arduino?

This is my first time I solder .. I tried my best to have clear soldering but I am not sure of the result.

I connect the arduino+motor shield to my computer using the USB cable .. the led on the Arduino turned on; but I am not sure about the motor shield ..

Thanks in advance guys for answering my simple questions...

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.
Maxhirez's picture
On the Arduino official R3 motor shield, you can apply 6-28v to the shield to drive the motors and it will power the Arduino itself. I wouldn't think either power configuration would be too damaging to the UNO or the shield if you had the right range for the motors themselves.
Geek07Boy's picture

Go to jameCo and to the part and at the bottom there is a link to the instructions on JameCo.

It looks like a good robot that is complete for the price.

Geek07Boy's picture

http://www.adafruit.com/

JameCo should have the PDFs, but the other site is where it came from.

Arduino,cc/en/ has PDFs and samples of code for all of your stuff.

I will look this stuff and correct myself if I am wrong.

 

AaahhhAndrew's picture

Hey Rabeeh. Your Arduino will power the motorsheild. The battery pack you hook to the motorsheild only provides power to the H-bridges on the motorsheild (as long at the EXT_PWR jumper is open). Think of it as you turning on a light switch. You dont actually power the light, you just turn the switch on. You were the Arduino and the light switch was the motorsheild. The H-bridges on the motorsheild will provide voltage to the motors you wire to it. As long as the battery voltage and current is within tolerances of the L293D H-bridges you will be fine. Each L293D can only handle spikes of 600 mA of current. Doing a little bit of Ohms law will help figure out what your motors will draw but based on your small motors you should be ok. Check out my robot as it may give you an idea of how to wire it. Just plug your servo on the top of the motorsheild on the header that says servo. Here are some of the pin configurations:


All 6 analog input pins are available. They can also be used as digital pins (pins #14 thru 19)

Digital pin 2, and 13 are not used.

Digital pin 11: DC Motor #1 / Stepper #1 (activation/speed control)
Digital pin 3: DC Motor #2 / Stepper #1 (activation/speed control)
Digital pin 5: DC Motor #3 / Stepper #2 (activation/speed control)
Digital pin 6: DC Motor #4 / Stepper #2 (activation/speed control)
These pins are in use only if the DC/Stepper noted is in use

Digital pin 4, 7, 8 and 12 are used to drive the DC/Stepper motors via the 74HC595 serial-to-parallel latch
These pins are in use if any DC/steppers are used

Digitals pin 9: Servo #1 control
Digital pin 10: Servo #2 control
These pins are used only if that particular servo is in use

rabeeh's picture

Thanks guys for your input and for sharing the link.. I am trying to figure out what to do now from the examples ...

The motor shield is in fact the one from adafruit and the instructions I got from jameco is to connect 7.5 volts to the EXT_PWR

The arduino is to be connected as per the instructions to 9 volts 

now I know that this is a bad idea ..

considering that I have 

1. 2 small motors + 1 hobby servo 

How do I make the power connection? :-S

Your motor shield looks like mine, which is based on the one from Adafruit and has flexible power options. Info here:

http://www.ladyada.net/make/mshield/use.html

The Arduino can take power from the shield directly; no need for two power sources. You may be able to do this too.

birdmun's picture

9v to the arduino's voltage regulator would cause it to have to disipate more power than if you were to use rechargeable cells and only feed the arduino 7.2v.

birdmun's picture

is not for the motor shield per se. The second pack is meant to be power for the motors and it will indeed connect in some way to the motor shield. I would also guess that rather than alkalines as you are considering, the packs were meant for rechargeables as they are rated at 1.2v. So, 6x1.2 = 7.2 and 5x1.2=6 which fits better with the specs I have seen on what the motors seem to be.

rabeeh's picture

Thanks for answer.

Yes I will be using the plug ...

I agree with you.. the instructions are vague.

Since I am using the motor shield with only 2 motors instead of 4 connected to it; would i need still the 5 AA batteries to power the motor shield ??

Thanks again guys.

Torrentula's picture

I understood from the site that the Arduino should be connected to the 9 Volts (6 AA) and the motor shield to the 7.5 Volts Is this correct?

As far as I can see from the pictures on the site yes, though the documentation on the Jameco site is a little bit unclear in my opinion.

The 9V wont blow the Arduino UNO, if you connect them properly. Are you using a center positive plug like they did on the Jameco site?

I don't use the motor shield so somebody else must answer questions regarding this.

 

Hope I could help

Torrentula