Let's Make Robots!

chinese 32 channel servo controler board

 I have chinese 32 channel servo driver board & it works well via USB cable with Win 7.  but i need to control this device wirelesly & i tried with APC 220 wireless module & some other bluetooth modules and didnt work.. both (APC 220 & bluetooth module) show the connection is established & receving data from pc by bliking orange led on servo board, when i move servo sliders in software. but servo does not work..  after few moves of servo slider, blinking orange LED also does not response. i used different baudrate but didnt success..

is there anyone who know about this...??? please help me...

AttachmentSize
32Servo Controller Manual1.pdf1.03 MB
APC220-HowTo-by_Nosepo.pdf233.46 KB
APC220Mannual.pdf264.05 KB
apc220_with_usb_to_UART_converter.JPG236.14 KB
yellow_-_RX__brown_TX_32_servo_board.JPG273.1 KB
yellow_-_TX__brown_-RX_apc_220.JPG229.62 KB
with_usb_cable.3GP938.92 KB
with_APC_220.3GP1.25 MB

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

yes.. i checked with different baud rate

Hi nilan,

Did you solve already this issue?

Did you change the baud rate of the BT unit itself?

thanks for your reply...

hear i atached all the manuals and photos and videos... (please sorry for the quality of videos and photos...) there are no codes for this and i used the software wich come with 32 servo controler board

thanks

 

 

OK, to begin with read all the manuals (again if necessary) because for anyone else to help you they will have to read the manuals.

Once you've read all the manuals (at least twice), if you still can't solve the problem then post all the manuals, or links to them in this forum so we can read them.

At the moment I only se the manual for the servo controller. Without the manuals for the transmitter and receiver we cannot be sure you have done everything correctly.

Post a clear, hi-resolution photo of your setup so we can check your wiring.

If you suspect your code is the problem then post that as well. Make sure you are sending bytes and not intergers or vice versa as required. Just because you have a blinky LED it does not mean you are receiving the correct data. It just means you are receiving something.

many thanks for your reply.....

(Not SSC-32 controler.., this is USC 32 channel servo controler from "torobot". manual is attached )

i connected TX to RX and RX to TX corectly...with APC 220 but didnt work.. one APC 220 module i connected to computer with  USB to UART converter which came with  APC 220 modules & other one connected 32 servo board.  this working very well with USB cabe.. signal receiving indicator (orange LED) on servo board shows it receving data when i move slider of software but servo not moving...

To begin with, if you search "32 channel servo driver" on the LMR site search you will see there are already about 5 or 6 different nodes about 32 channel servo drivers.

Also "chinese 32 channel servo driver" is not a part number. Almost everything is made in China so try to be more specific. Do you mean the SSC-32 controller from DFrobot?

Have you tested the servo controller without the wireless link first? If it is working ok then most likely you need to swap your RX and TX lines either between the Arduino and the transmitter or between the receiver and the servo driver (perhaps on both).

Remember that TX output goes to RX input.