Let's Make Robots!

Can't program picaxe 20m2

Hi,

Two days ago, i downloaded a simple debug ADC program onto my picaxe 20m2 to get adc values from an IR phototransistor. Code: main: readadc b.3, b0 debug goto main The program downloaded successfully and a window opened showing the adc values. Then I closed that debug window and made a few changes to my IR phototransistor circuit.

After making some changes I opened programming editor and selected Picaxe-> Debug... The debug window opened again and started showing the adc values, so far so good. But now when I try to download a new program, it shows that same old error that "Hardware not connected, Hardware not powered", etc... I don't understand, the debug is still working properly which means that there is no problem in my usb cable and picaxe. I even tried with new batteries and tried the hard reset as explained in picaxe manual 1, but still the same result. Any help will be greatly appreciated.

I also put the same forum at picaxe, here is the link -  http://www.picaxeforum.co.uk/showthread.php?22465-Help!-can-t-program-Picaxe-20m2! you may wanna see the replies.

Thank you.

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

don't know whether i was doing the hard reset procedure wrong but it is working properly now

Again the same situation, it got programmed only once with the blink led code. as debug was working ok before, now the blinking led is working properly but i am not able to program it again :(

Please read the Rules, sanc04 - then edit your post, or face death!

There you go, this is a very strict community ;)

I am so sorry.. I forgot not to start the subject with 'Help' :p

did you try the hard reset, do you have the caps in place.

did you try the hard reset, do you have the caps in place.