Let's Make Robots!

my first robot

moves around and scans for objects
Photo_15.jpg94.7 KB


what I am trying to do is make a mobile platform with a little breadboard on it so that I can try different projects. Underneath I have a l298 motor driver kit from solarbotics attached to the standard fa-130 motors that came with the tamiya gearbox. I had a hard time soldering the one lead of the caps onto the motor chassis, but the lead-to-lead caps are ok.


Im about to cut a hole in the front to mount the ping sensor and servo.


Everything works great when I have 2 seperate power sources, but ideally in the end I will have just one rechargable pack. Right now if I try to run both the Stamp project board and the motorcontroller from the same source, the stamp resets itself a couple of times a second. One person suggested a filtering capacitor for the motor controller, but I dont know anything about this.


My knowlege of electonics is really limited, but If you bear with me Ill be sure to keep you posted!

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

This is what people where talking about with the smoothing. 


Note that c1 and c2 go from + to -, these help to make sure you get continuos power to the chip...but you're also using the boe(homework board doesnt have these from my recolection), so you have the caps on the board already, and that board should be fairly solid.  What power source are you using? 9v batteries might not do it(low current) if thats what you use, if anything at least a 7+v power source(though 6 should work). 

 btw, check out this site for some useful knowledge on electronics!  I've found it very useful.


Nice to see another proc on here!