Let's Make Robots!

Subaru Wall Racer

Races around the room using ultrasound

I was inspired to make fritsl's wall racers when he showed them off in episode 18 of The latest in Hobby robotics on Makezine's youtube channel.  After finding his guide on how he made them I found where I could buy the parts and decided on a car that I would build it into.  I went with a Subaru Impreza R/C car off eBay which cost me $50AUD, a bit more expensive but worth the cost for the great looks!  For the brains I picked up the Picaxe 18M2 High Power project board and a L293D chip to controll the motors rather than use relays as fritsl did.  Two SRF05 Ultra Sonic range sensors are used for wall detection, a benifet of the new picaxe's is being able to use all pins as an input or output, because of this you are able to interface with the sensor using a single pin rather than the two pin method, one for input and one for output that the older picaxe's required.

Parts used:

1/18th Subaru Impreza WRC

Picaxe 18M2 High Power Board

2 x SRF05 Ultrasonic Range Sensors

And a whole bunch of wires, headers and plugs.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The car came with a very cheap remote that was not very good for driving, luckily we won't need it of the reciever circuit in the car.  So everything is stripped out of the car except the motors and LED lights.

Figuring out how to get all the new electronics in the tight space was hard and took a bit of fiddling around.

With everything working and fitting all that is left to do is fit the sensors to the outside and plug them in, then its just coding it till it works the way I want it to.  

Comment viewing options

Select your preferred way to display the comments and click "Save settings" to activate your changes.

Did you solder the the capacitor to the Sensor, or can I put a cap on the end of the plug, where it meets my breadboard.

I inserted the cap into the molex pin that the sensor plugs into. It had plenty of room.  I only mention adding a capicitor in case anyone else runs into unexpected readings.  Seems to happen when the battery starts getting low.  

I found that when using my MAXIM ic step up DC - DC (AKA mintyboost), the sensor gives me crap values if they are over 30cm, if they are lower it will still register, but with terrible accuracy. Numbers all over the place.

My robot constantly pinged between left and right sensors with all kinds of weird readings.  Weirdness (zero distance or far away) all went away after adding 100nF capacitor between the 5v and ground on each sensor. Very cool car!

Thats strange that you had issues mine is fine without any capacitors on the sensors.