Let's Make Robots!

Attiny Interrupts and communication

Hi everyone!

For the past few days I have been working on a "smart" servo. Basically, I want the precision of a standard servo combined with continuous rotation and low costs. 

The plan is: Put two brightness sensors on one of the inner gears and use them as a quadrature encoder to calculate the angle. This value is then sent to an arduino or directly used to reach a set position. 

What I have done so far:

I decided to use a HK15138 Servo from Hobbyking because they are about the cheapest servos you can find at this size.

A small update on a project.

Hi guys o/

It feels like an eternity since I talked to you all :D But LMR is up and sadly I don't see the SB! Anyways, it should be up anytime soon as frits and blue and everyone are indeed working super hard on addressing the issue.

Device signature 0x000000 while burning bootloader

Hi LMR,

So I bought 7 Atmega328's and burned bootloader's into 5 of them.However for 2 of them I get the following error:

avrdude: Device signature = 0x000000
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

I'm using Arduino Duemilanove as ISP and got the com settings,board selection and programmer settings correct.

MDIBs - Metadata Driven Internet Brains

I'm always asking myself, "What is logical for how to build a smarter bot with today's tech and the tech soon to come?"  

Max did it!!

he final broke the SB with MR speedo,:

 

Help with Beaglebone Black balancing robot

Hello everyone, I want to start by saying this question post might become long and I hope you guys hang on and are able to help me. So here we go :)

First of all the robot is barely able to balance. Here is a video of the robot trying to balance. The problem seems to be that the robot is not able to reach the setpoint fast enough. This is a speculation so you guys give me your ideas on what the problem is also.

picaxe and Sparkfun COM-11644

I am trying to get a Sparkfun COM-11644 working using a serial connection from a Picaxe 08m2.  I have tried every combination of 08m2 pins and commands and the display responds to nothing.

The connections from the 08m2 are Vcc, Gnd and c.4 as the serial pin.  I also have this post on the Picaxe forum and have gotten several replies all of which I have tried with no success and I have sent an email to Sparkfun technical support (no response yet).

The current code is here:

#picaxe 08m2

#no_data

#com 3

setfreq m8

 

Ears?

Right now I'm not really concerned with understanding the sound, but more with localizing it so I can point the bot's head at the speaker.

I was thinking of two cheap microphones with something behind them that would absorb sound. Then I could just focus on anything I could hear with both mikes and point the head until the sound is the loudest in both ears. If the sound is directly behind the bot, it should be possible to determine this by a very small microphone in the rear of the head.

Has anybody used a scheme like this?

Get $10 Back for 3D Printer DIY Kit For Reprap Prusa Mendel i3

ICStation is into the 3D printer market now. And the first DIY kits is online for sell. We had provided with detailed installation info and debugging tips for learner/ hobbyists.